revIgniter Naming Convention
revIgniter follows a simple, easy to memorize, naming convention to reduce potential name conflicts to a minimum:
All revIgniter functions and commands are prefixed either with rig or _rig for some private handlers, they look something like rigSampleFunction or _rigSampleFunction. Besides those listed below, global variables use gRig and constants rig as prefix. Furthermore flash is a reserved prefix. This means, with few exceptions (see below), you can choose arbitrary names for your functions, commands, globals and constants as long as you don't prefix them with rig, _rig, gRig or flash.
Note: revIgniter (as of version 1.3.15b) no longer supports former names (those without prefix). All users are asked to replace those names by prefixing them with rig before upgrading to version 1.3.15b or higher. So for example convert loadHelper to rigLoadHelper, fetchConfigItem() to rigFetchConfigItem() etc.
Following is a list of reserved names that cannot be used.